Okay
  Public Ticket #1786848
.map problem
Closed

Comments

  • ssamacsupport started the conversation

    I have this ".map" error.  And I cannot resolve it.

    Can you help me with this?  I have try lots of method including delete this last line in the script which is for example as below

    //# sourceMappingURL=popper.min.js.map

    It still cannot work.. Same problem.

    How can I resolve it?  Thanks.

    Attached files:  Screenshot 2018-11-17 at 10.54.20 AM.png

  •  99
    Jyostna replied

    Hello,

    Can you please check the file with the name toastr.js.map in (node_modules/toastr/) in your project structure, if it is found it will fix.
    Otherwise delete node_modules folder and run the following command
    yarn install 

    If yarn install success run the below command
    npm run dev 


    then check the output

    Thanks

  • ssamacsupport replied

    There is no (node_modules) in my public folder.  

    So I have follow your steps to install npm .. But I still failed..  

  • ssamacsupport replied

    I have try installing the npm outside the public folder, still met with the same problem.

    At least now, I know the root cause is npm.

    If any other advice, please advice me.  Thanks.

  •  99
    Jyostna replied

    Hello,

    Please,explain the steps from the beginning that you had followed to install clear.

    Thanks,

  • ssamacsupport replied

    I am using docker.

    So in the container, I have install nginx 1.15.6, PHP 7.2.12.

    Then I go install laravel 5.7.12 and install npm.

    After that, I copy your file over.

  •  99
    Jyostna replied

    Hello,

    Can i know with which folder you are working in clear.

    Thanks,

  •  99
    Jyostna replied

    Hello,

    If suppose ,if you are using "laravel" folder to install please follow below steps 

    1.)composer install
    2.)cp .env.example .env
    3.)php artisan key:generate
    3.)yarn install
    4.)npm run dev

    Please,check the below documentation link it may helps you.
    https://lorvent.gitbooks.io/clear/content/laravel-version.html

    Further any issues let me know.

    Thanks,

  • ssamacsupport replied

    I just copy & paste your folders as it is..

    Attached files:  Screenshot 2018-11-19 at 6.26.36 PM.png

  •  99
    Jyostna replied

    Hello,

    No,it is not like that.

    When you unzip the "clear" downloaded folder from themeforest. You may find the sub folders like
    1.)html
    2.)laravel
    3.)vue   ....etc

    Choose required folder ,and copy the project folder in your html (var/www/html)

    And follow the steps for installation ,as given below.

    Thanks,



  • ssamacsupport replied

    Yup.. That's what I did..  Copy & paste the laravel folder from your zip file.

    Except that I did not read your installation steps.  So now I am trying on that.

    Thanks!!

    Hope it will works!  Will get back to you soon!

  • ssamacsupport replied

    Boss, your bower is dying....
    Will you be updating your package to more updated one?

    Your Clear Template is a very good template for laravel.

    Please do not worry.  I will continue to buy the latest version of yours.

    Anyway, I am still trying to follow your instructions. Let you know shortly.  Still installing.

  •  99
    Jyostna replied

    Hello,

    If you find any bower.json file in your project folder,then only you need to run bower install.

    Thanks,

  • ssamacsupport replied

    I give up........

    I follow the exact same step.

    It does not matter right if I am using alpine 3.8 instead of ubuntu right?

  •  99
    Jyostna replied

    Hello,

    Did you solve the issue ? otherwise

    please once again start the installation from the beginning in your laravel folder

    1. yarn install (if success)

    2. composer install (if success)

    3. cp .env.example .env

    4. php artisan key:generate

    5. npm run dev


    note: before installation of above steps you need to have the system configuration i.e. you must have yarn, npm, composer,php in your system.

    if any issues, let me know


    Thanks,

  • ssamacsupport replied

    1) Successful

    2) Successful

    3) Successful

    4) Successful

    5) Successful

    Attached files:  Screenshot 2018-11-20 at 9.06.20 AM.png
      Screenshot 2018-11-20 at 9.06.37 AM.png

  • ssamacsupport replied

    Once strange thing.

    1) Google Chrome, no error

    2) Safari, still unable to find that .map

    3) Firefox, unable to find that .map

  •  99
    Jyostna replied

    Hello,

    Please check the below link ,it may helps you
    https://github.com/CodeSeven/toastr/issues/244

    Thanks,

  • ssamacsupport replied

    Nope.  Not this issue.  It already without the slash. 

  •  99
    Jyostna replied

    Hello,

    Can you,Please check with the latest release,link attached as below

    https://drive.google.com/file/d/1L8J4SwEZbAtoWh2SHvX7gNDGZONA759V/view?usp=sharing

    It is working fine with no errors.

    Thanks,

  • ssamacsupport replied

    Thanks so much for the effort.

    The error still come out when I use "npm run dev".

    But when I use "npm run production", 99% of the .map error disappeared.  I will still to this for the time being.

    Thank you so much!  Really really appreciate it very much!

  • ssamacsupport replied

    Can I know how to resolve the problem?  Can teach me?  Then I can change on my side as well.  Thanks.

    There are a few features having the .map problem.

    1. Gallery - Dropify (css.map)
    2. Gallery - Image-Hover (css.map)
    3. Pages - Reset Password (popper.js.map)
    4. Dashboard 1 - (flip.min.js.map)
    5. Layouts - Movable header (custom's/layout.css)
  •  99
    Jyostna replied

    Hello,

    please, Can you tell me the which operating system you are using.

    Thanks

  • ssamacsupport replied

    I am using docker -> Alpine 3.8 with Nginx 1.1.5.6 with php fpm 7.2.12.

  • ssamacsupport replied

    So can teach me how to resolve that 5 features with .map problem?

    Thanks.

  •  99
    Jyostna replied

    Hello,

    As previous state, you are getting the error in safari browser. So, i think  it is an browser issue of missing some packages, so please once uninstall and install it once again.If it not fix, try it in other operating system.


    Thanks,